KITO

SYSTEM REQUIREMENTS

For secure and comfortable viewing and usage of the KITO Web site, the following operating system, browser and plug-in software are required. KITO strongly recommends that users first confirm the version of their software before downloading.

Minimum OS and Browser Requirements

  • Internet Explorer 8.x 9.x 10.x
  • Google Chrome latest ver.

Plug-in Requirements

  • Flash Player
    Browsing of certain pages in this Web site requires the installation of Macromedia Flash Player 5 or higher.
  • Acrobat Reader
    Viewing and/or printing of PDF files require installation of Adobe Acrobat Reader 4.0 or higher.

Please click the following sites to download the latest version of above-mentioned browser and plug-in.

Browser
Plug-in
Page Top

PLEASE UPGRADE YOUR BROWSER TO EXPERIENCE THIS SITE

this page is best viewed with